Changelog

This changelog is used to track all major changes to Mopidy.

For older releases, see History.

v3.0.1 (2019-12-22)

Bugfix release.

  • Remove mopidy.local migration helper. (Fixes: #1861, PR: #1862)

v3.0.0 (2019-12-22)

The long-awaited Mopidy 3.0 is finally here, just in time for the Mopidy project’s 10th anniversary on December 23rd!

Mopidy 3.0 is a backward-incompatible release in a pretty significant way: Mopidy no longer runs on Python 2.

Mopidy 3.0 requires Python 3.7 or newer.

While extensions have been able to continue working without changes throughout the 1.x and 2.x series of Mopidy, this time is different:

  • All extensions must be updated to work on Python 3.7 and newer.

  • Some extensions need to replace their use of a few long-deprecated APIs that we’ve removed. See below for details.

  • Extension maintainers are also encouraged to update their project’s setup to match our refreshed extension cookiecutter.

In parallel with the development of Mopidy 3.0, we’ve coordinated with a few extension maintainers and upgraded almost 20 of the most popular extensions. These will all be published shortly after the release of Mopidy 3.0.

We’ve also built a new extension registry, where you can quickly track what extensions are ready for Python 3.

In other news, the Mopidy-MPD and Mopidy-Local extensions have grown up and moved out to flourish as independent extension projects. After the move, Mopidy-Local merged with Mopidy-Local-SQLite and Mopidy-Local-Images, which are now both a part of the Mopidy-Local extension.

Dependencies

  • Python >= 3.7 is now required. Python 2.7 is no longer supported.

  • GStreamer >= 1.14.0 is now required.

  • Pykka >= 2.0.1 is now required.

  • Tornado >= 4.4 is now required. The upper boundary (< 6) has been removed.

  • We now use a number of constants and functions from GLib instead of their deprecated equivalents in GObject. The exact version of PyGObject and GLib that makes these constants and functions available in the new location is not known, but is believed to have been released in 2015 or earlier.

Logging

  • The command line option mopidy --save-debug-log and the configuration logging/debug_file have been removed. To save a debug log for sharing, run mopidy -vvvv 2>&1 | tee mopidy.log or equivalent. (Fixes: #1452, PR: #1783)

  • Replaced the configurations logging/console_format and logging/debug_format with the single configuration logging/format. It defaults to the same format as the old debug format. (Fixes: #1452, PR: #1783)

  • Added configuration logging/verbosity to be able to control logging verbosity from the configuration file, in addition to passing -q or -v on the command line. (Fixes: #1452, PR: #1783)

Core API

  • Removed properties, methods, and arguments that have been deprecated since 1.0, released in 2015. Everything removed already has a replacement, that should be used instead. See below for a full list of removals and replacements. (Fixes: #1083, #1461, PR: #1768, #1769)

Root object

  • Removed properties, use getter/setter instead:

    • mopidy.core.Core.uri_schemes

    • mopidy.core.Core.version

Library controller

Playback controller

  • Removed properties, use getter/setter instead:

    • mopidy.core.PlaybackController.current_tl_track

    • mopidy.core.PlaybackController.current_track

    • mopidy.core.PlaybackController.state

    • mopidy.core.PlaybackController.time_position

  • Moved to the mixer controller:

  • Deprecated the tl_track argument to mopidy.core.PlaybackController.play(), with the goal of removing it in the next major release. Use the tlid argument instead. (Fixes: #1773, PR: #1786, #1854)

Playlist controller

  • Removed properties, use getter/setter instead:

    • mopidy.core.PlaylistController.playlists

  • Removed methods:

    • mopidy.core.PlaylistsController.filter(): Use as_list() and filter yourself.

    • mopidy.core.PlaylistsController.get_playlists(): Use as_list() and get_items().

Tracklist controller

Backend API

Models

Extension support

HTTP frontend

  • Stop bundling Mopidy.js and serving it at /mopidy/mopidy.js and /mopidy/mopidy.min.js. All Mopidy web clients must use Mopidy.js from npm or vendor their own copy of the library. (Fixes: #1083, #1460, PR: #1708)

  • Remove support for serving arbitrary files over HTTP through the use of http/static_dir, which has been deprecated since 1.0. (Fixes: #1463, PR: #1706)

  • Add option http/default_app to redirect from web server root to a specific app instead of Mopidy’s web app list. (PR: #1791)

  • Add cookie secret to Tornado web server, allowing Tornado request handlers to call get_secure_cookie(), in an implementation of get_current_user(). (PR: #1801)

MPD frontend

  • The Mopidy-MPD frontend is no longer bundled with Mopidy, and has been moved to its own Git repo and PyPI project.

Local backend

  • The Mopidy-Local backend is no longer bundled with Mopidy, and has been moved to its own Git repo and PyPI project. (Fixes: #1003)

  • Removed mopidy.exceptions.FindError, as it was only used by Mopidy-Local. (PR: #1857)

Audio

  • Remove the method mopidy.audio.Audio.emit_end_of_stream(), which has been deprecated since 1.0. (Fixes: #1465, PR: #1705)

  • Add live_stream option to mopidy.audio.Audio.set_uri() that disables buffering, which reduces latency before playback starts, and discards data when paused. (PR: #1845)

Internals

  • Format code with Black. (PR: #1834)

  • Port test assertions from unittest methods to pytest assert statements. (PR: #1838)

  • Switch all internal path handling to use pathlib. (Fixes: #1744, PR: #1814)

  • Remove mopidy.compat and all Python 2/3 compatibility code. (PR: #1833, #1835)

  • Replace requirements.txt and setup.py with declarative config in setup.cfg. (PR: #1839)

  • Refreshed and updated all of our end user-oriented documentation.