Arch Linux: Install from community

If you are running Arch Linux, you can install Mopidy using the mopidy package found in community.

  1. To install Mopidy with all dependencies, you can use:

    pacman -S mopidy
    

    To upgrade Mopidy to future releases, just upgrade your system using:

    pacman -Syu
    
  2. Finally, you need to set a couple of config values, and then you’re ready to run Mopidy or run Mopidy as a service.

Installing extensions

If you want to use any Mopidy extensions, like Spotify support or Last.fm scrobbling, AUR has packages for lots of Mopidy extensions.

You can also install any Mopidy extension directly from PyPI with pip. To list all the extensions available from PyPI, run:

pip search mopidy

Note that extensions installed from PyPI will only automatically install Python dependencies. Please refer to the extension’s documentation for information about any other requirements needed for the extension to work properly.

For a full list of available Mopidy extensions, including those not installable from AUR, see Extensions.